• Project: Joomla!
  • Deelproject: Alle
  • Ernst: Laag
  • Versies: 1.5.14 en alle eerdere releases 1.5
  • Exploit type: Openbaarmaking Uitbreiding Versie
  • Gemeld Datum: 13-oktober-2009
  • Vaste datum: 2009-nov-03

Beschrijving

Het is mogelijk om de inhoud van de verlenging een XML-bestand te lezen en vind het versienummer van de geïnstalleerde extensies. Dit zou Bekend om mensen in staat om beveiligingsfouten te benutten voor een specifieke versie van een verlenging.

Getroffen Installeert

Alle 1.5.x installeert vóór tot en met 1.5.14 worden getroffen.

Oplossing

Inschakelen en configureren van uw Apache mod_rewrite. Htaccess bestand te filteren op XML-bestanden. In het htaccess.txt bestand geleverd met versie 1.5.15, lijnen 35-39 bevatten voorbeeld code dat de toegang tot XML-bestanden zal ontkennen. U kunt bouwde deze code (of een soortgelijke code) in uw. Htaccess-bestand. Zorg ervoor dat dit examen, dat het veroorzaakt geen problemen op uw site.

Gemeld door WHK en GERG? Erd? Is

Questo pagina è disponibile anche in: Duits Italiaans Spaans

Geef een antwoord